Emails Delayed
Incident Report for DigitalOcean
Resolved
The issue causing emails to be delayed has been resolved. Please open a ticket for our support team if you still see any problems using your account.
Posted 20 days ago. Jul 04, 2017 - 17:00 UTC
Monitoring
Email delivery times have stabilized and should be back to normal. If you still experience any problems with Droplet password resets, logging in to your account, confirming your email, etc., please try again to request a new email be sent. You can also email contact@digitalocean.com to reach our support team if you're unable to log in to the control panel.
Posted 20 days ago. Jul 04, 2017 - 16:23 UTC
Update
We apologize for the continued mail delays. We are continuing to investigate an issue with an upstream mail provider.
Posted 21 days ago. Jul 04, 2017 - 03:45 UTC
Investigating
We are seeing reports of delayed emails from our cloud control panel. These involve email confirmations, password resets, verification emails, and things of that nature. Our engineers are currently investigating this issue.
Posted 21 days ago. Jul 04, 2017 - 02:00 UTC
This incident affected: Services (Cloud Control Panel).