Errors Saving New Billing Profiles
Incident Report for DigitalOcean
Resolved
We have resolved the issue adding a credit card as a new billing profile to an account. We apologize for any inconveniences.
Posted 23 days ago. Nov 21, 2017 - 17:01 UTC
Monitoring
Our engineering team has fixed the issue with saving a new billing profile to an account, and users should now be able to add a credit card. We are monitoring the fix, and ask that you open a ticket for our support team if you continue to experience any issues.
Posted 23 days ago. Nov 21, 2017 - 16:40 UTC
Investigating
We are investigating errors in the control panel associated with saving a new billing profile to an account. Currently, users may be unable to add a credit card, but are able to make a PayPal payment, if needed. We will share additional updates as we have more information.
Posted 23 days ago. Nov 21, 2017 - 15:53 UTC
This incident affected: Services (Cloud Control Panel).