Email Delivery Delays
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue causing delays with emails being sent from DigitalOcean accounts. Thank you for your patience, and should you continue to experience problems please open a ticket with our support team.
Posted 12 days ago. Sep 10, 2018 - 21:18 UTC
Monitoring
Our engineering team has implemented a fix for the issue causing delays with emails being sent from DigitalOcean accounts and is monitoring the situation. We will post an update as soon as additional information is available.
Posted 12 days ago. Sep 10, 2018 - 20:30 UTC
Identified
Our engineering team has identified the cause of the issue with delays in emails being sent from DigitalOcean accounts and is actively working on a fix. We will post an update as soon as additional information is available.
Posted 12 days ago. Sep 10, 2018 - 20:10 UTC
Investigating
Our engineering team is investigating an issue with delays in emails being sent from DigitalOcean accounts, including emails related to password resets, device verification, newly created Droplets, and other user notifications. We apologize for the inconvenience and will share an update once we have more information.
Posted 13 days ago. Sep 10, 2018 - 19:24 UTC
This incident affected: Regions (Global).