Control Panel Connectivity & Event Processing
Incident Report for DigitalOcean
Resolved
Our engineers have resolved the issue causing delays in event processing. We apologize for any issues that this may have caused for you. If you're still experiencing delays at this time please open a support ticket.
Posted 3 months ago. May 10, 2017 - 03:22 UTC
Monitoring
We have isolated and resolved the on going issues. We will continue to monitor events. If you're still experiencing delays we ask that you please open a support ticket.
Posted 3 months ago. May 10, 2017 - 01:55 UTC
Update
Our engineers are continuing to work through the outstanding issues at this time. Most event issues have been resolved.
Posted 3 months ago. May 10, 2017 - 00:47 UTC
Update
We are still continuing to work through outstanding issues. Most event issues have been resolved at this time.
Posted 3 months ago. May 10, 2017 - 00:09 UTC
Update
Events remain steady and the number of outstanding issues continues to decrease.
Posted 3 months ago. May 09, 2017 - 23:06 UTC
Update
No further problems with events have occurred and we continue to reduce the number of outstanding issues.
Posted 3 months ago. May 09, 2017 - 22:36 UTC
Update
Events have been reenabled. We are still experiencing a few outlying issues but that small subset has been identified and we are in the process of resolving them.
Posted 3 months ago. May 09, 2017 - 21:59 UTC
Update
All events are currently delayed or may fail in some regions. Our engineers are continuing to roll out a fix to resolve this issue. We are bringing regions back online in stages to keep event traffic steady.

Droplets and other existing services (Load Balancers, Block Storage, Monitoring, etc.) are up and running and should not be impacted.

Thank you for you patience and we apologize for any inconvenience that this causes for you. We will continue to keep you posted as we apply the fix to all regions.
Posted 3 months ago. May 09, 2017 - 21:28 UTC
Update
Our engineering team is continuing to roll out a fix to fully resolve the issue. Events will continue to be disabled at this time, though some events that are already processing will fail or complete sporadically. This currently affects all regions. Thank you for you patience and we apologize for any inconvenience that this causes for you.
Posted 3 months ago. May 09, 2017 - 20:25 UTC
Update
Our engineering team is currently rolling out a fix to fully resolve the issue. Events will continue to be disabled at this time, though some events that are already processing will fail or complete sporadically. Thank you for you patience and we apologize for any inconvenience that this causes for you.
Posted 3 months ago. May 09, 2017 - 19:31 UTC
Identified
At this time, our engineering team has disabled event processing in all regions and are working to fully mitigate the issue. We apologize for any inconvenience that this causes for you.
Posted 3 months ago. May 09, 2017 - 18:47 UTC
Update
Our engineering team is actively monitoring the issue and have found that events are also affected. During this time you may experience stalled or failing events. We apologize for any inconvenience that this causes for you.
Posted 3 months ago. May 09, 2017 - 18:19 UTC
Monitoring
Connectivity to our control panel has been restored and we will continue to monitor until it is fully resolved.
Posted 3 months ago. May 09, 2017 - 17:49 UTC
Investigating
Our engineering team is actively investigating intermittent connectivity issues to our cloud control panel.
Posted 3 months ago. May 09, 2017 - 17:38 UTC
This incident affected: Regions (Global) and Services (Event Processing).