PayPal Payment Delays
Incident Report for DigitalOcean
Resolved
The issue with PayPal payment delays is resolved and new payments should be processed like normal. if you still see a problem with any of your recent payments updating your account balance, please open a ticket for our Support team.
Posted 3 months ago. Jul 26, 2017 - 18:50 UTC
Monitoring
The issue causing delays with PayPal payment processing has been fixed. New payments should be processed normally, but recent payments from the last two days that haven't been applied to your account balance yet may still take an additional 24 hours to finish processing.
Posted 3 months ago. Jul 26, 2017 - 12:23 UTC
Identified
At this time we have identified the issue causing delays with balance updates after some payments using PayPal. We will continue to work with the appropriate teams to reduce the impact.
Posted 3 months ago. Jul 25, 2017 - 04:58 UTC
Investigating
At this time you may experience delays with your balance being updated after making a payment using PayPal. Our engineers are now investigating this issue and we will provide an update as soon as possible.
Posted 3 months ago. Jul 24, 2017 - 22:59 UTC
This incident affected: Regions (Global).