Networking Issues in Multiple Regions
Incident Report for DigitalOcean
Resolved
Our Engineering and Trust & Safety teams took action to block TCP/8083 and stop outgoing traffic from affected Droplets. These mitigation efforts have fully resolved the networking issues impacting our NYC1 and SFO2 regions, and users should now be able to access the site normally. If you continue to experience issues, please open a ticket with our support team.

Though the networking issues have been resolved, TCP/8083 will remain blocked for now. Additionally, users with VestaCP software installed on their Droplets may be vulnerable to exploitation. For more details about the vulnerability, please refer to this Q&A: https://do.co/vesta-vuln
Posted 4 months ago. Apr 08, 2018 - 21:51 UTC
Update
Our Engineering and Trust & Safety teams took action to block TCP/8083 and stop outgoing traffic from affected Droplets. These mitigation efforts appear to have resolved the networking issues impacting our NYC1 datacenter, and we are monitoring the situation until it is fully resolved. We continue to work to resolve the issues impacting SFO2, and will post an update as soon as possible.
Posted 4 months ago. Apr 08, 2018 - 20:26 UTC
Update
Our Engineering and Trust & Safety teams continue to work to resolve the incident impacting networking connectivity in our NYC1 and SFO2 regions. Our initial actions, including blocking TCP/8083 and stopping outgoing traffic from affected Droplets, appear to be helping to mitigate the issue, but the incident remains on-going.

We have identified users with potentially impacted Droplets and we are sending an email to these users detailing the actions we've taken to protect your Droplets from further exploitation, as well as steps you can take to ensure your Droplets are as secure as possible. For more details about the vulnerability, please refer to this Q&A: https://do.co/vesta-vuln
Posted 4 months ago. Apr 08, 2018 - 20:00 UTC
Update
Our Engineering and Trust & Safety teams continue to work to resolve the incident impacting networking connectivity in our NYC regions. Our initial actions, including blocking TCP/8083 and stopping outgoing traffic from affected Droplets, appear to be helping to mitigate the issue, but the incident remains on-going.

We have identified users with impacted Droplets and will be sending emails detailing the actions we've taken to protect your Droplets from further exploitation, as well as steps you can take to ensure your Droplets are as secure as possible. Additionally, we will soon post a Q&A providing additional information and guidance for users, and will provide a link to that information once it has been posted.
Posted 4 months ago. Apr 08, 2018 - 18:51 UTC
Update
Our Engineering and Trust & Safety teams continue to work to resolve the incident impacting networking connectivity in our NYC regions. Our initial actions, including blocking TCP/8083 and stopping outgoing traffic from affected Droplets, appear to be helping to mitigate the issue. We will provide additional updates as soon as more information is available.
Posted 4 months ago. Apr 08, 2018 - 16:24 UTC
Update
Our engineering team continues to work to resolve the networking issue impacting our NYC regions. We believe a previously undisclosed vulnerability in software by some customers on their Droplets is allowing for denial of service (DoS) attacks against targets outside of DigitalOcean. Our Trust & Safety team is also engaged to resolve this incident; in an effort to protect unaffected Droplets, we will block inbound traffic to TCP/8083.

We will continue to post updates here as more information becomes available, and we will provide additional guidance for customers to determine whether their Droplets are impacted, and how to work around the block to continue to safely access their software.
Posted 4 months ago. Apr 08, 2018 - 15:22 UTC
Update
Our engineering team continues to work on resolving the networking issue impacting our NYC regions. We apologize for any inconvenience and will post additional information here as it becomes available.
Posted 4 months ago. Apr 08, 2018 - 13:37 UTC
Identified
Our engineering team has identified the cause of the issue with network in our NYC regions and is actively working on a fix. We will post an update as soon as additional information is available.
Posted 4 months ago. Apr 08, 2018 - 12:02 UTC
Update
Our engineering team continues to investigate the issue with network that is currently impacting NYC regions. We appreciate your patience and will post an update as soon as additional information is available.
Posted 4 months ago. Apr 08, 2018 - 10:45 UTC
Investigating
Our engineering team is investigating an issue with network in our NYC regions. We apologize for the inconvenience and will share an update once we have more information.
Posted 4 months ago. Apr 08, 2018 - 09:49 UTC
This incident affected: Regions (NYC1, SFO2) and Services (Networking).