Promotional Credit Issues
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with promotional credits. Applying promotional credits should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 9 days ago. Oct 07, 2018 - 13:39 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with applying promotional credits to your account and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 9 days ago. Oct 07, 2018 - 13:24 UTC
Identified
Our engineering team has identified the cause of the delay when applying promotional credits to your account and is actively working on a fix. We will post an update as soon as additional information is available.
Posted 9 days ago. Oct 07, 2018 - 13:07 UTC
Investigating
Our engineering team is investigating an issue with promotional credits. During this time, you may experience a delay in your account balance being updated when applying promotional credits. We apologize for the inconvenience and will share an update once we have more information.
Posted 9 days ago. Oct 07, 2018 - 12:58 UTC