Cloud Control Panel DNS Management Issue
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with DNS Management Page. Users should now be able to manage their Domain's DNS. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 27 days ago. Sep 19, 2018 - 11:42 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with DNS Management Page. We are monitoring the situation at this point. We will post an update as soon as the issue is fully resolved.
Posted 27 days ago. Sep 19, 2018 - 10:53 UTC
Investigating
Our engineering team is investigating an issue with loading the DNS management page under Domain Networking. During this time, you may experience issues in loading or editing your Domain's DNS . We apologize for the inconvenience and will share an update once we have more information.
Posted 27 days ago. Sep 19, 2018 - 10:00 UTC
This incident affected: Regions (Global) and Services (DNS, Networking).