Cloud Control Panel Errors
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with accessing the billing section of the Cloud Control Panel. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 3 months ago. Aug 28, 2018 - 23:32 UTC
Monitoring
Our engineering team has implemented a fix to restore access to the Billing area in the Cloud Control Panel. We are continuing to monitor the situation, and will post an update once we can confirm full resolution.
Posted 3 months ago. Aug 28, 2018 - 23:01 UTC
Identified
Our engineering team has identified an issue related to the billing section of the Cloud Control Panel and is working towards a solution. During this time, users may receive error messages when attempting to access or perform actions within this section of the Cloud Control Panel. We apologize for the inconvenience and will share an update once we have more information.
Posted 3 months ago. Aug 28, 2018 - 22:45 UTC
This incident affected: Services (Cloud Control Panel).