Power Off Event Delays
Incident Report for DigitalOcean
Resolved
This incident has been resolved.
Posted 3 months ago. Mar 04, 2018 - 21:34 UTC
Monitoring
Our engineering team has identified an issue impacting power off events, causing some users to experience delays when powering off a Droplet. Power off events are currently processing normally, and we are continuing to monitor the situation.
Posted 3 months ago. Mar 04, 2018 - 20:38 UTC
This incident affected: Regions (Global) and Services (Event Processing).