Errors Accessing Billing in Cloud Control Panel
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with the billing page in our Cloud Control Panel. The billing page should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 3 months ago. Jul 02, 2019 - 02:35 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with the billing page in our Cloud Control Panel and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 3 months ago. Jul 02, 2019 - 02:10 UTC
Identified
Our engineering team has identified the cause of the issue with the billing page in our Cloud Control Panel and is actively working on a fix. We will post an update as soon as additional information is available.
Posted 3 months ago. Jul 02, 2019 - 01:52 UTC
Investigating
Our engineering team is currently investigating issues accessing the billing page in our Cloud Control Panel. Users may receive an error, or otherwise find the billing page inaccessible when attempting to use this feature. We apologize for the inconvenience and will share an update once we have more information.
Posted 3 months ago. Jul 02, 2019 - 01:31 UTC
This incident affected: Regions (Global) and Services (Billing, Cloud Control Panel).