Billing Delays
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue impacting billing delays, and balances are now correct for all users. If you continue to experience problems, please open a ticket with our support team. We apologize for the inconvenience.
Posted 6 months ago. Jun 02, 2018 - 00:35 UTC
Monitoring
Our Engineering Team has implemented a fix to resolve the issue with billing discrepancies and balances should now be accurately displayed on users’ accounts. We are monitoring the situation and will post another update as soon as we confirm full resolution.
Posted 6 months ago. Jun 01, 2018 - 23:44 UTC
Update
Our engineering team has identified an issue with incorrect balance amounts. Users will see a balance that only includes charges for June usage, and does not reflect outstanding charges for May usage. Automated billing is unaffected, but users will be unable to see the amount charged until the issue is resolved. While we work to resolve, we do not recommend using the "pay now" option in the billing panel, as the balance displayed is inaccurate and you may be charged again at the end of the month. We apologize for the inconvenience and will post an update as soon as the issue is resolved and balances are displaying accurately.
Posted 6 months ago. Jun 01, 2018 - 13:04 UTC
Identified
Our engineering team has identified the cause of the issue with our billing and is actively working on a fix. We will post an update as soon as additional information is available.
Posted 6 months ago. Jun 01, 2018 - 11:21 UTC
Update
We are continuing to investigate this issue.
Posted 6 months ago. Jun 01, 2018 - 10:15 UTC
Investigating
Our engineering team is investigating an issue with our billing. During this time, you may experience delayed generation of invoices and balance due might not reflect as expected. We apologize for the inconvenience and will share an update once we have more information.
Posted 6 months ago. Jun 01, 2018 - 10:13 UTC
This incident affected: Regions (Global).