Issue with Contact page
Incident Report for DigitalOcean
Resolved
Our engineering team has deployed a fix that has resolved the Contact page issue, and you should have no trouble using it. If you continue to experience any issues with it, please open a ticket with our support team. We apologize for the inconvenience this may have caused.
Posted 29 days ago. Nov 15, 2018 - 23:26 UTC
Identified
Our engineering team has identified the cause of an issue with our Contact page and is actively working on a fix. We will post an update as soon as additional information is available. In the meantime, email us directly at contact@digitalocean.com for any questions.
Posted 29 days ago. Nov 15, 2018 - 22:54 UTC