Email issues with support@digitalocean.com address
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with opening support tickets via support@digitalocean.com and it should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 3 months ago. Jan 09, 2019 - 06:11 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issues with opening support tickets via support@digitalocean.com and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 3 months ago. Jan 09, 2019 - 05:36 UTC
Identified
Our engineering team has identified the cause of the issues with opening support tickets via support@digitalocean.com and is actively working on a fix. Please use customer portal to create tickets during this time. We sincerely apologize for any inconvenience this may have caused.
Posted 3 months ago. Jan 09, 2019 - 04:48 UTC
Investigating
Our engineering team is investigating issues with opening support tickets via support@digitalocean.com. We apologize for the inconvenience and will share an update once we have more information. During this time, tickets can still be created via customer portal.
Posted 3 months ago. Jan 09, 2019 - 03:29 UTC
This incident affected: Regions (Global).