PayPal Payment Delays
Incident Report for DigitalOcean
Resolved
At this time our engineers have confirmed that PayPal has resolved these delays. Should you see any further issues, please open a support ticket.
Posted 7 months ago. May 31, 2017 - 14:57 UTC
Monitoring
At this time our engineers have confirmed that PayPal is aware of these delays and actively looking into this issue. We will be continually monitoring this behavior ourselves and will provide another update once we have confirmed that payments made using PayPal are being processed normally.
Posted 7 months ago. May 31, 2017 - 11:35 UTC
Investigating
At this time you may experience delays with your balance being updated after making a payment using PayPal. Our engineers are now investigating this issue and we will provide an update as soon as possible.
Posted 7 months ago. May 31, 2017 - 11:20 UTC