Support tickets undelivered via "support@support.digitalocean.com"
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved this issue affecting delivery of support tickets sent to support@support.digitalocean.com. Sorry for the trouble!
Posted 3 months ago. Aug 30, 2017 - 21:50 UTC
Investigating
Our engineers are investigating an issue impacting the delivery of support tickets from emails manually sent to support@support.digitalocean.com. Emails sent to this address will not be seen by our support team until this issue is resolved. Emails sent to support@digitalocean.com are still being received.
Posted 3 months ago. Aug 26, 2017 - 01:38 UTC
This incident affected: Services (Support Center).