Global Droplet Creation Issues
Incident Report for DigitalOcean
Resolved
Our engineering team has confirmed resolution of the issues with creation failures. All systems should be operating normally. If you continue to experience any problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Dec 16, 2019 - 17:32 UTC
Monitoring
Our Engineering team has identified the issue with creation failures, and users should no longer be experiencing issues at this time. Our team is now monitoring the situation for any further issues. We apologize for the inconvenience and will share an update once we have confirmed that the issue is resolved.
Posted Dec 16, 2019 - 15:25 UTC
Investigating
Our Engineering team is investigating an issues with creation failures in our regions. During this time, users may experience issues or errors while attempting to create Droplets. We apologize for the inconvenience and will share an update once we have more information.
Posted Dec 16, 2019 - 14:58 UTC
This incident affected: Regions (Global) and Services (Event Processing).