PayPal payment processing failures
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue with processing payments via PayPal on our platform. Services should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Feb 13, 2020 - 17:01 UTC
Monitoring
Our Engineering team has identified the cause of the issue with processing payments via PayPal on our platform, and has implemented a fix. We are currently monitoring the situation and will post an update as soon as the issue is fully resolved.
Posted Feb 13, 2020 - 14:33 UTC
Investigating
Our Engineering team is investigating an issue with payments using PayPal. During this time, you may experience timeouts/failures when trying to use PayPal. We apologize for the inconvenience and will share an update once we have more information.
Posted Feb 13, 2020 - 10:51 UTC
This incident affected: Regions (Global) and Services (Billing).