Support Portal Issues
Incident Report for DigitalOcean
Resolved
This incident has been resolved.
Posted 18 days ago. May 08, 2019 - 22:40 UTC
Update
Our engineering team has resolved the issue with our Support Portal. The Support Portal should now be operating normally. If you continue to experience problems opening a support ticket, please reach out to us via our contact form:
https://www.digitalocean.com/company/contact/#support. We apologize for any inconvenience.
Posted 18 days ago. May 08, 2019 - 22:39 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with the Support Portal and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 18 days ago. May 08, 2019 - 21:02 UTC
Update
Our engineering team continues to work to resolve the issue with our Support Portal. During our investigation, we learned that users who had active DigitalOcean accounts before May 8, 03:00 UTC, are able to submit tickets normally though the Cloud Control Panel. However, users who signed up for DigitalOcean after May 8, 03:00 UTC, are unable to submit tickets through the Cloud Control Panel while we work to resolve this issue. In the meantime, you can continue to reach out to us via our contact form:
https://www.digitalocean.com/company/contact/#support

We apologize for any inconvenience, and will post a further update as soon as additional information is available.
Posted 19 days ago. May 08, 2019 - 18:10 UTC
Identified
Our engineering team has identified the cause of the issue with our Support Portal, and is actively working on a fix. In the meantime, you can continue to reach out to us via our contact form:
https://www.digitalocean.com/company/contact/#support

We will post an update as soon as additional information is available.
Posted 19 days ago. May 08, 2019 - 07:41 UTC
Investigating
Our engineering team is investigating an issue with our Support Portal. At this time we are seeing delays in support email delivery and contact form submissions.

In the meantime, you can continue to reach out to us via our contact form:
https://www.digitalocean.com/company/contact/#support

We apologize for the inconvenience and will share an update once we have more information.
Posted 19 days ago. May 08, 2019 - 05:35 UTC
This incident affected: Regions (Global) and Services (Support Center).