Email messages not reaching the Support team.
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with email deliverability to the support team. The support system should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Nov 05, 2019 - 04:43 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with email deliverability to the support team and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Nov 05, 2019 - 04:15 UTC
Investigating
Our engineering team is investigating an issue with emails sent to our Support team not being properly received. If you have emailed our Support team we may not have received your email. The primary method of reaching our Support team is through the Support Portal, which can be accessed by logging in to https://cloudsupport.digitalocean.com/ . We apologize for the inconvenience and will share an update once we have more information.
Posted Nov 05, 2019 - 03:42 UTC
This incident affected: Services (Support Center).