Global Droplet Creation
Incident Report for DigitalOcean
Resolved
We've confirmed the issue with creation of Droplets and Droplet-based products is fully resolved. Thank you for your patience. If you continue to experience any problems, please open a support ticket from within your account
Posted Jun 28, 2022 - 22:54 UTC
Monitoring
Our engineering team identified the root cause of the issue and has deployed a fix. As of 22:19 UTC, users should no longer experience creation failures and can safely retry creation actions via API and Cloud Control Panel. We're monitoring the fix and will post an update once we confirm this incident is fully resolved.
Posted Jun 28, 2022 - 22:30 UTC
Investigating
As of 22:09 UTC, our Engineering team is investigating an issue with Droplet creation in all regions. At this time users will see creation failures for Droplet and Droplet-based products such as Kubernetes, Managed Databases, and Load Balancers, both via API and Cloud Control Panel. We will share an update once we have further information
Posted Jun 28, 2022 - 22:19 UTC
This incident affected: Regions (Global) and Services (Droplets, Kubernetes, Load Balancers, Managed Databases).