Support Portal Issues
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with our Support Portal. The Support Portal should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 9 days ago. May 17, 2019 - 22:30 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with our Support Portal and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 9 days ago. May 17, 2019 - 21:16 UTC
Investigating
Our engineering team is investigating an issue with our Support Portal. During this time, users may experience issues accessing the support portal, and reviewing tickets. We apologize for the inconvenience and will share an update once we have more information.
Posted 10 days ago. May 17, 2019 - 17:39 UTC
This incident affected: Services (Support Center).