Issue Impacting New Account Registrations
Incident Report for DigitalOcean
Resolved
Our engineers have resolved the issue impacting new account registrations, and all services appear to be functioning normally at this time. Thank you for your patience throughout this process, and we apologize for the inconvenience. If you notice any further issues at all, then please contact Support right away.
Posted Jan 05, 2021 - 21:00 UTC
Monitoring
Our engineers have implemented a fix for the issue impacting new account registrations, and are monitoring the situation closely. We will post another update once we're confident that the issue is fully resolved.
Posted Jan 05, 2021 - 20:37 UTC
Investigating
Our engineering team is currently investigating an issue impacting new account registrations. During this time, new users may experience problems when trying to complete the registration process, particularly on the "Registration complete! Let's make something" step. We apologize for the inconvenience and will share an update once we have more information.
Posted Jan 05, 2021 - 20:05 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).