Errors with Control Panel Billing Page
Incident Report for DigitalOcean
Resolved
Our engineering team has confirmed resolution of the issue impacting the Billing page in our Cloud control panel. All systems should be operating normally at this time. If you continue to experience any problems, then please open a ticket with our support team. We apologize for any inconvenience, and we appreciate your patience throughout this process.
Posted Feb 19, 2020 - 20:53 UTC
Monitoring
Our engineering team has implemented a fix for the issue impacting the Billing page in our Cloud control panel, and are currently monitoring the situation. We will post an update once we feel the situation is fully resolved.
Posted Feb 19, 2020 - 20:36 UTC
Investigating
Our engineering team is currently investigating an issue impacting the Billing page in our Cloud control panel. During this time, users may experience errors while accessing the Billing page of the control panel. We apologize for the inconvenience and will share an update once we have more information.
Posted Feb 19, 2020 - 20:23 UTC
This incident affected: Regions (Global) and Services (Billing, Cloud Control Panel).