Cloud Control Panel Issues
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with the Cloud Control Panel. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 16 days ago. Nov 02, 2018 - 17:56 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with the Cloud Control Panel and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 16 days ago. Nov 02, 2018 - 15:45 UTC
Investigating
Our engineering team is investigating an issue with Cloud Control Panel. During this time you may experience slow loading and updating of the panel. We apologize for the inconvenience and will share an update once we have more information.
Posted 16 days ago. Nov 02, 2018 - 14:59 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).