Monitoring Alerts for MongoDB Cluster
Incident Report for DigitalOcean
Resolved
After further investigation, our Engineering team has discovered that monitoring alerts, other than disk usage, have been triggering correctly for MongoDB clusters, but have been missing cluster information, such as the name of the cluster in the email subject line.

Additionally, there is a known issue with disk usage alerts for MongoDB clusters that has been present since the launch of the product.

A small number of clusters are impacted. We apologize for any miscommunication and misunderstanding. At the outset of this incident, with the data available, we believed this to be much more impactful.

Our Engineering team will work to correct the missing cluster information in triggered alerts to improve the customer experience. Longer-term work is planned to allow for successful disk alerts for MongoDB clusters as well. Given this, we’ll close this public incident.
If you have any questions or concerns, please reach out to Support from within your account. Thank you.
Posted Mar 17, 2023 - 16:15 UTC
Identified
As of 13:35 UTC, our Engineering team has identified the issue with Monitoring alerts for MongoDB Clusters and is working on a fix. We will post an update as soon as additional information is available.
Posted Mar 17, 2023 - 13:51 UTC
Investigating
Our Engineering team is investigating an issue with Monitoring alerts for MongoDB Clusters in all region. During this time, alert policies may be delayed or fail to trigger their configured notification options. We apologize for the inconvenience, and we'll share an update once we have more information.
Posted Mar 17, 2023 - 12:47 UTC
This incident affected: Regions (Global) and Services (Monitoring).