Adding Payment Methods.
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with setting up payment methods. Adding payment methods should now process normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Jul 26, 2021 - 22:37 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with setting up payment methods and is monitoring the situation. You should now be able to add a new payment method to your account without issue. We apologize for the inconvenience and will post an update as soon as this issue is fully resolved.
Posted Jul 26, 2021 - 21:53 UTC
Investigating
Our engineering team is investigating an issue with setting up payment methods. At this time, users may experience errors when creating a new account or attempting to add a new payment method to an existing account. We apologize for the inconvenience and will share an update once we have more information.
Posted Jul 26, 2021 - 21:27 UTC
This incident affected: Services (Billing).