Network Outage in EU affecting AMS1 and AMS2
Incident Report for DigitalOcean
Resolved
Telia has repaired their issue and we've returned all routing to normal.
Posted over 4 years ago. May 19, 2014 - 22:06 UTC
Monitoring
As we mentioned previously, we have routed around the affected network provider. Unfortunately, since this is a widespread problem affecting a significant portion of all Internet traffic between North America and Europe, you may continue to see degraded performance.
Posted over 4 years ago. May 19, 2014 - 21:07 UTC
Update
We are currently making network changes in an attempt to route around the affected networks. We will provide additional updates as we have more information.
Posted over 4 years ago. May 19, 2014 - 20:35 UTC
Investigating
At this time we're experience a network outage in our AMS1 and AMS2 datacenters. With secondary impact affecting customers in Europe. As a result, you may experience latency, connectivity issues, or slow pings.

Preliminary investigation indicates that Telias Transatlantic cable are down. We are working to resolve the issue and apologize for any interruption this causes for you.
Posted over 4 years ago. May 19, 2014 - 20:29 UTC