Droplet Creation via Cloud Control Panel
Incident Report for DigitalOcean
Resolved
From 17:22 - 18:42 UTC, users were unable to create Droplets in the Cloud Control Panel due to an incorrect UI/UX change. The public API remained fully functional.

We've confirmed this incident is resolved. If you continue to experience any issues, please open a support ticket from within your account. Thank you.
Posted Mar 10, 2023 - 19:26 UTC
Monitoring
The rollback has completed and we've confirmed the change that we rolled back was the root cause of the issue with creating Droplets from the Cloud Control Panel. Users are able to create Droplets normally at this time. We're now monitoring the situation and will post an update once we confirm this incident is fully resolved.
Posted Mar 10, 2023 - 18:52 UTC
Update
Our team has identified a probable root cause. We are in the process of rolling back to mitigate the issue as well as confirm the cause of the issue. We'll post an update once the rollback has completed.
Posted Mar 10, 2023 - 18:26 UTC
Investigating
Our Engineering team is investigating an issue with creating Droplets via the Cloud Control Panel. At this time, users may see nothing happening when selecting all options and then attempting to create a Droplet in the control panel. Creation via the public API does not appear to be impacted. We will provide an update as soon as we have further information.
Posted Mar 10, 2023 - 18:06 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).