Support Portal Ticket Creations
Incident Report for DigitalOcean
Resolved
Our Engineering team has identified the root cause of the issue with ticket creation from the Support Portal and a fix has been deployed.

From May 24 19:56 to May 27 18:00 UTC, users were unable to submit tickets for a subset of Ticket Topics. This issue is now resolved. We apologize for any inconvenience.
Posted May 27, 2022 - 18:10 UTC
Investigating
Our Engineering team is investigating an issue with the ticket creation on the Support Portal. During this time some users may face issues while creating a new support ticket from the support portal. We apologize for the inconvenience and will share a further update at our earliest.
Posted May 27, 2022 - 17:36 UTC
This incident affected: Regions (Global) and Services (Support Center).