Email issues with support@digitalocean.com address
Incident Report for DigitalOcean
Resolved
Our email vendor has resolved the issue that impacted inbound emails to our support team. Tickets sent to support@digitalocean.com are now being added to our queues. We apologize for any inconvenience caused and thank you for your patience while we worked through this.
Posted 5 months ago. Feb 06, 2019 - 15:41 UTC
Monitoring
Our email vendor has resolved the issue on their side, and mail has begun arriving to our systems again. Emailed tickets sent to support@digitalocean.com are now properly being added to our queues. Mail messages that were sent to us while the issue was ongoing have been received, and our support team are working through the backlog. We apologize for the inconvenience and appreciate your patience thus far.
Posted 5 months ago. Feb 05, 2019 - 23:21 UTC
Update
Our email vendor is currently experiencing issues with incoming messages, and as a result tickets submitted to us via email are not being added to our queue. According to the vendor, this issue may last several days or longer. While we await a resolution, we ask that you please open a ticket from your account via: https://cloudsupport.digitalocean.com/s/createticket. We apologize for the inconvenience and any extended wait time you may have experienced awaiting a response from our support team.
Posted 5 months ago. Feb 05, 2019 - 16:23 UTC
Identified
Our engineering team has identified the cause of the issue with opening support tickets via support@digitalocean.com and is actively working on a fix. We will post an update as soon as additional information is available.

In the meantime, we request you to create tickets from your account via:
https://cloudsupport.digitalocean.com/s/createticket
Posted 6 months ago. Feb 04, 2019 - 10:52 UTC
Investigating
Our engineering team is investigating issues with opening support tickets via support@digitalocean.com. In the meantime, we request you to create tickets from your account via:
https://cloudsupport.digitalocean.com/s/createticket
We apologize for the inconvenience and will share an update once we have more information. During this time, tickets can still be created via customer portal.
Posted 6 months ago. Feb 04, 2019 - 08:32 UTC
This incident affected: Regions (Global) and Services (Support Center).