Kubernetes cluster creation.
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed full resolution of the issue with the Kubernetes page in the Cloud Control Panel. We also confirmed behavior via the API was not impacted for this incident.

We apologize for any inconvenience and thank you for your patience throughout this process.
Posted Jun 27, 2022 - 16:09 UTC
Monitoring
As of 15:27 UTC, our Engineering team has implemented a fix to resolve the issue with the Kubernetes page in the Cloud Control Panel. At this time, functionality should be restored. We are monitoring the fix and will post an update once we confirm full resolution.
Posted Jun 27, 2022 - 15:34 UTC
Investigating
As of 14:41 UTC, our Engineering team is investigating reports of users unable to correctly use the Kubernetes page in the Cloud Control Panel. At this time, users may see errors in the control panel and be unable to create new Kubernetes clusters or access existing clusters. We will post another update once we have further information.
Posted Jun 27, 2022 - 15:00 UTC
This incident affected: Regions (Global) and Services (Kubernetes).