Cloud Control Panel Connectivity
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue with our Cloud Control Panel. All aspects of https://cloud.digitaloocean.com should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Oct 12, 2020 - 14:17 UTC
Monitoring
Our Engineering team has identified the issue and implemented a fix to resolve the issue with our Cloud Control Panel. We are currently monitoring the situation and will post an update as soon as the issue is fully resolved.
Posted Oct 12, 2020 - 13:46 UTC
Investigating
Our Engineering team is investigating an issue with our Cloud Control Panel. During this time, users may experience errors reaching https://cloud.digitalocean.com, issues while signing in there, as well as issues navigating the Cloud Control Panel. We apologize for the inconvenience and will share an update once we have more information.
Posted Oct 12, 2020 - 13:25 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).