Cloud Control Panel
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue impacting Cloud Control Panel and all services should now be functioning normally. Thank you for your patience throughout this process. If you experience any further issues at all, please open a ticket with our Support team.
Posted Jul 20, 2021 - 20:59 UTC
Monitoring
Our Engineering team is currently monitoring an issue impacting Cloud Control Panel functionality. Between approximately 18:30 UTC and 19:30 UTC today, some users may have experienced errors or blank pages in the Cloud Control Panel, particularly when trying to view or deploy apps via App Platform. A fix has already been implemented, and we will continue to monitor the situation closely. We apologize for the inconvenience and will share another update once the matter is fully resolved.
Posted Jul 20, 2021 - 20:02 UTC
This incident affected: Regions (Global) and Services (App Platform, Cloud Control Panel).