SSL Certificate creation
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed resolution of the issue with Let's Encrypt SSL Certificates, and all services should now be operating normally. If you continue to experience any issues, please open a Support ticket from within your account. Thank you for your patience!
Posted May 05, 2021 - 10:27 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue with creating SSL certificates and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted May 05, 2021 - 09:44 UTC
Identified
Our Engineering team has identified the cause of the issue with Let's Encrypt SSL certificates and is actively working on a fix. We will post an update as soon as additional information is available.
Posted May 05, 2021 - 08:40 UTC
Investigating
Our Engineering team is investigating an issue with our Let's Encrypt SSL certificates. During this time, you may experience issues with creating SSL certificates for Load Balancers and Spaces. We apologize for the inconvenience and will share an update once we have more information.
Posted May 05, 2021 - 06:47 UTC
This incident affected: Regions (Global) and Services (Load Balancers, Spaces).