Droplet Create Issues
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with Droplet creates. They should now be operating normally. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 7 days ago. Jul 13, 2018 - 21:35 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with problematic Droplet creates and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 8 days ago. Jul 13, 2018 - 20:56 UTC
Investigating
Our engineering team is investigating an issue with Droplet creates in all regions. During this time, you may experience delays or errors with Droplet creates. We apologize for the inconvenience and will share an update once we have more information.
Posted 8 days ago. Jul 13, 2018 - 20:42 UTC
This incident affected: Regions (Global) and Services (Droplets, Event Processing).