Spaces availability in AMS3
Incident Report for DigitalOcean
Resolved
Our Engineering team has completed remediation work to address the key issues responsible for this incident and we are now marking this issue as resolved. Our Spaces Engineers will now begin proactive maintenance to further improve the performance and reliability of Spaces in our AMS3 region and this work will be documented in a separate maintenance post. We apologize for the inconvenience and we greatly appreciate your patience throughout this process. If you should have any questions or concerns regarding this matter, please open a ticket with our Support team.
Posted Jun 01, 2021 - 18:39 UTC
Update
Our engineering teams have completed all hardware swaps and augmentations. Users should begin to see an improvement in error rates and Spaces functionality.
Work continues to fully resolve this issue, however, due to the nature of the work involved, there is no timeline for full resolution. We understand that this has been a long process and appreciate your continued patience.
Posted May 31, 2021 - 23:41 UTC
Update
Multiple teams are now engaged in working to mitigate the issues for a subset of Spaces in our AMS3 region. At this time, hardware swaps and augments are in progress and this work will continue for some time. Due to the nature of the issue, we do not have a clear ETA, but best estimates indicate this work should be finished in approximately six hours.

After the hardware work is completed, users should begin to see improved error rates and Spaces functionality. We understand this has been a long process and appreciate your continued patience.
Posted May 31, 2021 - 14:13 UTC
Update
Our Engineering team carries on the mitigation work with Spaces issues in our AMS3 region. A portion of Spaces users in this region may continue facing increased error rates when using Spaces API. Our team is actively working on a fix, however, we don't have an ETA to resolution time yet. We apologize for the inconvenience and will share an update as soon as there is further progress.
Posted May 30, 2021 - 18:46 UTC
Update
Our Engineering team has identified the cause of the issue with some Spaces in our AMS3 region and the work to fix the issue is continuing. We will post an update as soon as additional information is available.
Posted May 30, 2021 - 05:58 UTC
Identified
Our Engineering team has identified the cause of the issue with Spaces in our AMS3 region and is actively working on a fix. We will post an update as soon as additional information is available.
Posted May 29, 2021 - 18:08 UTC
Investigating
Our Engineering team is investigating an issue with Spaces availability in our AMS3 region. During this time you may experience an increased error rate when using the Spaces system. We apologize for the inconvenience and will share an update once we have more information.
Posted May 29, 2021 - 14:58 UTC
This incident affected: Regions (AMS3) and Services (Spaces).