Droplet Creation in AMS2 and AMS3
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed full resolution of the issue with Droplet creation in AMS2 and AMS3. From 20:30 - 21:40 UTC, users were unable to create Droplets and Droplet-based services in the affected regions.

We apologize for the inconvenience. If you're still experiencing any issues, please open a support ticket.
Posted Jul 06, 2022 - 23:45 UTC
Monitoring
A fix has been fully implemented and we are monitoring the situation to ensure no further errors. We will post a final update once we have confirmed resolution of this incident.
Posted Jul 06, 2022 - 22:24 UTC
Identified
Our Engineering team has identified the cause of the issue with creation of Droplets and Droplet-based services in AMS2 and AMS3 and is working to resolve it. At this time, users should be able to create resources in AMS2 and AMS3 once again. We will post a further update once a fix has been fully implemented.
Posted Jul 06, 2022 - 21:59 UTC
Update
As our team continues to investigate, we have confirmed our AMS2 region is impacted as well. Users are also unable to deploy Droplets and Droplet-based services in AMS2 as of 20:30 UTC.
Posted Jul 06, 2022 - 21:40 UTC
Investigating
Our Engineering team is investigating an issue with creation of Droplets and Droplet-based services in our AMS3 region. As of 20:30 UTC, users are unable to deploy Droplets, Load Balancers, Managed Databases, and Kubernetes Clusters in the AMS3 region.

We will provide an update as soon as possible.
Posted Jul 06, 2022 - 21:22 UTC
This incident affected: Regions (AMS2, AMS3) and Services (Event Processing).