Customer Support Ticket Portal
Incident Report for DigitalOcean
Update
Our Engineering team has observed recurrences of this incident and we are in communication with our vendor to find a permanent solution. We expect further improvement actions to take place on Monday, November 28.

Over the next two days, users may intermittently continue to experience issues while logging into our Support portal at https://cloudsupport.digitalocean.com/. As a temporary workaround, users may still contact us via the form here:
https://www.digitalocean.com/company/contact/support

We will post another update here by 20:00 UTC Monday, November 28. We appreciate your patience and understanding. If you have any questions or concerns in the meantime, please feel free to let us know.
Posted Nov 25, 2022 - 17:47 UTC
Identified
Our Engineering team has identified a recurrence of this incident and is actively engaging with our vendor to investigate the situation further.

As a reminder, please use our contact form at the following link as a temporary workaround: https://www.digitalocean.com/company/contact/support

We apologize for the inconvenience and will post an update as soon as further information is available.
Posted Nov 24, 2022 - 06:32 UTC
Monitoring
We've completed maintenance on our Support Portal and have verified that users are able to submit tickets via https://cloudsupport.digitalocean.com normally. With the recommended fixes from our vendor now in place, we'll continue to monitor this incident over the next 24 hours to ensure the fixes are successful and prevent the intermittent issues we have been seeing.

We encourage all users to submit tickets normally through their DigitalOcean account Support Portal. If you encounter an error, please feel free to use the alternate form and let us know.

Thank you for your patience throughout this process!
Posted Nov 23, 2022 - 22:27 UTC
Update
We are currently conducting maintenance to implement potential fixes recommended by our vendor. Please follow https://status.digitalocean.com/incidents/spwkwfjgky7r for maintenance updates.
Posted Nov 23, 2022 - 21:13 UTC
Update
Our Engineering team continues to work with our vendor to find a permanent solution.

As this issue is intermittent, we expect users will be able to log support tickets normally. However, during any periods of unavailability, as a temporary workaround, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

Thank you for your patience. We will post an update as soon as more information becomes available.
Posted Nov 22, 2022 - 07:31 UTC
Update
Our Engineering team will continue to work with our vendor over the weekend to find a permanent solution. Users may continue to observe an "Oops, Something Went Wrong" error when trying to access the support portal.

As this issue is intermittent, we expect users will be able to log support tickets normally. However, during any periods of unavailability, as a temporary workaround, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

Thank you for your patience. We will post an update as soon as more information becomes available.
Posted Nov 19, 2022 - 02:15 UTC
Update
Our Engineering team has observed recurring instances of this incident that intermittently continue to impact our Support portal at https://cloudsupport.digitalocean.com/. We are aware of these events and our engineers are working with our vendor to resolve this.

At this time, users may observe an "Oops, Something Went Wrong" error when trying to access the support portal. As a temporary workaround, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

Thank you for your patience. We will post an update as soon as information becomes available
Posted Nov 18, 2022 - 14:43 UTC
Update
As of 23:00 UTC, the intermittent issue with logging into our support portal at https://cloudsupport.digitalocean.com/ has subsided.

The cause has been identified as a potential upstream issue with our vendor. Our Engineering team is actively working with our vendor to debug and put a fix in place.

At this time, users should be able to log in normally. If we observe a recurrence or when we receive further information about a fix, we'll post an update here.
Posted Nov 17, 2022 - 23:11 UTC
Update
Our Engineering team has identified a recurrence of this incident and is actively engaging with our vendor to investigate the situation further.

As a reminder, please use our contact form at the following link as a temporary workaround: https://www.digitalocean.com/company/contact/support
Posted Nov 17, 2022 - 18:20 UTC
Update
The cause of the intermittent issue with logging into our support portal at https://cloudsupport.digitalocean.com/ has been identified as a potential upstream issue with our vendor. Our Engineering team is actively working with our vendor to debug and put a fix in place.

We've confirmed this is a recurrence of the previous issue posted here: https://status.digitalocean.com/incidents/2y2f3ry5b7b6

At this time, users should be able to login normally. If we observe a recurrence or when we receive further information about a fix, we'll post an update here.
Posted Nov 17, 2022 - 15:48 UTC
Identified
Our Engineering team has identified the cause of the issue with accessing the support portal and is actively working on a fix. During this time, users might face login issues to our support portal at https://cloudsupport.digitalocean.com. We will post an update as soon as additional information is available
Posted Nov 17, 2022 - 12:10 UTC
Investigating
Our Engineering team is investigating an issue with customers being unable to login to our support portal at https://cloudsupport.digitalocean.com.

At this time, users may observe an "Oops, Something Went Wrong" error on the page. As a temporary workaround, users may still contact us via the form here: https://www.digitalocean.com/company/contact/support

We apologize for the inconvenience and will post an update as soon as further information is available.
Posted Nov 17, 2022 - 09:55 UTC
This incident affects: Regions (Global) and Services (Support Center).