Our Engineering team has confirmed that the issue impacting payments made on the DigitalOcean platform has been fully resolved. Between 08:00 UTC and 15:34 UTC customer accounts may have been temporarily suspended even after successful payment of their monthly bill was remitted.
If you continue to experience problems, please open a ticket with our support team from within your Cloud Control Panel. Thank you for your patience and we apologize for any inconvenience.
Posted Jan 21, 2023 - 17:00 UTC
Monitoring
Our Engineering team has put a fix in place for the issue impacting payments made on the DigitalOcean platform. At this time users should no longer experience any issues with Accounts being suspended after successful payment remittance. We will continue to monitor the situation and provide a final update once we confirm the issue has been fully resolved. Thank you for your patience and we apologize for the inconvenience.
Posted Jan 21, 2023 - 15:49 UTC
Identified
Our Engineering team has identified the cause of the issue with payments made on the DigitalOcean platform and is actively working on a fix. During this time, users may experience issues with Accounts being suspended even after successful payment. We will post an update as soon as additional information is available
Posted Jan 21, 2023 - 12:53 UTC
Investigating
Our Engineering team is investigating an issue with payments made on the DigitalOcean platform. As of 08:00 UTC, users may experience issues with Accounts being suspended even after successful payment. We apologize for the inconvenience and will share an update once we have more information.
Posted Jan 21, 2023 - 12:21 UTC
This incident affected: Regions (Global) and Services (Billing).