Issues Adding New Credit Cards
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue preventing some users from adding new credit cards from the control panel. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted 27 days ago. May 21, 2018 - 19:42 UTC
Monitoring
Our engineering team has implemented a fix to resolve issues that some users experienced when attempting to add new credit cards to the Cloud Control Panel. We are monitoring the situation and will post an update as soon as the issue is fully resolved.
Posted 27 days ago. May 21, 2018 - 18:59 UTC
Investigating
Our engineering team is investigating reports of issues occurring when users attempt to add a new credit card in the billing settings page of the Cloud Control Panel. During this time, some users may be unable to input card information because the field where users supply their card number is not rendering. We apologize for the inconvenience and will share an update once we have more information.
Posted 27 days ago. May 21, 2018 - 18:22 UTC
This incident affected: Services (Cloud Control Panel).