Delayed Ticket Creation via Contact Form
Incident Report for DigitalOcean
Resolved
The recent issue with our contact form has been resolved, and our support team has addressed all inbound requests. We appreciate your patience while we worked to fix this issue and respond to inquires. You should no longer experience issues or delays with submitting requests through our contact form.
Posted about 1 hour ago. Dec 15, 2017 - 01:56 UTC
Identified
We have identified the issue with our contact form and have begun working toward a resolution. Once we've solved the problem, we will re-enable our contact form. Until then, please email contact@digitalocean.com or submit a ticket from our control panel. If you have reached out recently via our contact form and have not heard back, your request has not been lost, but there will be a delay in processing it. If you require support more urgently please contact the e-mail address above. We apologize for the inconvenience.
Posted 14 days ago. Nov 30, 2017 - 22:42 UTC
Update
We have temporarily disabled the contact form while we work to resolve the issues causing delays with ticket creation. Until the issue is fixed, please email contact@digitalocean.com or submit a ticket directly through the control panel if you need assistance from our support team. We appreciate your patience, and apologize for any inconveniences.
Posted 17 days ago. Nov 27, 2017 - 23:22 UTC
Investigating
We are investigating an issue where messages submitted through our contact form are experiencing delays creating tickets in our support center. This issue may lead to a delay in response time from our support team. As we work to correct this issue, we recommend that users in need of support log into the control panel to submit tickets, or email us at contact@digitalocean.com.
Posted 17 days ago. Nov 27, 2017 - 18:40 UTC
This incident affected: Services (Support Center).