Cloud Control Panel Team Creations
Incident Report for DigitalOcean
Resolved
Our Engineering team has completely resolved the issues with Team account creations in our Cloud Control Panel, and all services should now be operating normally. Thank you for your patience throughout this process. And if you continue to experience problems, then please open a ticket with our support team.
Posted Oct 08, 2021 - 14:36 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issues with Team account creation failures and is monitoring the situation closely. We will post an update as soon as the issue is fully resolved.
Posted Oct 08, 2021 - 14:06 UTC
Investigating
Our Engineering team is currently investigating an issue with Team creations in Cloud Control Panel. During this time, when users attempt to create a new Team account, they may experience errors on the third step "Invite Members". We apologize for the inconvenience and will share an update once we have more information.
Posted Oct 08, 2021 - 12:58 UTC
This incident affected: Regions (Global) and Services (Billing).