New Account Creation Errors
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue impacting new account creations. Users should be able to create new accounts using a credit card as the payment method at this time. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Dec 15, 2020 - 23:47 UTC
Monitoring
Our Engineering team has implemented a fix to resolve the issue impacting new account creation and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted Dec 15, 2020 - 23:12 UTC
Identified
Our Engineering team has identified the issue impacting new account creation and is actively working on a fix. We will post an update as soon as additional information is available.
Posted Dec 15, 2020 - 22:43 UTC
Investigating
Our Engineering team is investigating an issue impacting new account creations. During this time, users may experience difficulty creating new accounts when using a credit card as the payment method. We apologize for the inconvenience and will share an update once we have more information.
Posted Dec 15, 2020 - 22:36 UTC
This incident affected: Regions (Global) and Services (Billing).