Delayed Ticket Creation via Contact Form
Incident Report for DigitalOcean
Resolved
The recent issue with our contact form has been resolved. We appreciate your patience while we worked to fix this issue, our Support team will be working on replying to all of the inquiries as quickly as possible. You should no longer experience issues or delays with submitting requests through our contact form.
Posted Aug 24, 2018 - 16:35 UTC
Monitoring
Our engineering team has implemented the fix to resolve contact form issues, we are no longer seeing problems at this time. The team will continue to monitor the issue to ensure problems do not reoccur. Any submission to the form will now respond with a confirmation email. If you continue to not see these please reach out to our Support team by emailing contact@digitalocean.com.
Posted Aug 24, 2018 - 16:03 UTC
Identified
Our engineering team has identified the issue impacting the contact form and is working on a fix. Users should now be able to submit tickets through the contact form without issue, but there may be a delay in processing inquires that were submitted during this incident, and some users' tickets may not have been received at all. To confirm your issue was received, look for a confirmation email in your inbox. If you do not see a confirmation email we encourage you to resubmit your ticket to contact@digitalocean.com directly. We apologize for the inconvenience, and will share an update as soon as the issue is fully resolved.
Posted Aug 24, 2018 - 15:41 UTC
Investigating
We are investigating an issue where messages submitted through our contact form are experiencing delays creating tickets in our support center. This issue may lead to a delay in response time from our support team. As we work to correct this issue, we recommend that users in need of support log into the control panel to submit tickets, or email us directly at contact@digitalocean.com.
Posted Aug 24, 2018 - 14:56 UTC
This incident affected: Regions (Global) and Services (Support Center).