Spaces, App Platform and Container Registry
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed that this incident impacting Spaces, App Platform, and DigitalOcean Container Registry users in the NYC3 region has been fully resolved.

From 10:45 UTC - 17:35 UTC users may have experienced an increased error rate when accessing Spaces objects and errors while interacting and authenticating with the DigitalOcean Container Registry, creating new container registries, and pushing/deleting images to/from registries. App Platform users may have also experienced build failures.

If you continue to experience any issues with these services please submit a ticket to our customer support team for assistance. Thank you for your patience.
Posted Nov 17, 2022 - 19:54 UTC
Monitoring
At 17:30 UTC our Engineering team deployed a permanent fix to the issue impacting App Platform, Spaces, and Container Registry services in the NYC3 region. We have not seen any further reports of ongoing issues related to this incident, but we will continue to monitor the situation for a while longer to ensure stability.

As soon as we have confirmation that the incident has been fully resolved we will provide a final update. Thank you again for your patience.
Posted Nov 17, 2022 - 18:04 UTC
Identified
As of 16:25 UTC, our Engineering team has identified the issue impacting App Platform, Spaces, and Container Registry services in the NYC3 region. A temporary fix has been employed to mitigate customer impact. Users should no longer experience any issues from this incident, however we are closely monitoring performance as a permanent fix is being established. We will provide another update as soon as more details are available.

Thank you for your patience and we apologize for the inconvenience.
Posted Nov 17, 2022 - 16:45 UTC
Update
As of 12:30 UTC, on further investigation, our Engineering team found that this issue is impacting Spaces, App Platform, and DigitalOcean Container Registry users in the NYC3 region. At this time, users may experience an increased error rate when accessing Spaces objects and errors while interacting and authenticating with the DigitalOcean Container Registry, creating new container registries, and pushing/deleting images to/from registries.

App Platform users may experience build failures.

We apologize for the inconvenience and will share an update once we have more information.
Posted Nov 17, 2022 - 12:43 UTC
Update
As of 12:30 UTC, on further investigation, our Engineering team found that this issue is impacting Spaces, App Platform, and DigitalOcean Container Registry users in the NYC3 region. At this time, users may experience an increased error rate when accessing Spaces objects and errors while interacting and authenticating with the DigitalOcean Container Registry, creating new container registries, and pushing/deleting images to/from registries.

App Platform users may experience build failures.

We apologize for the inconvenience and will share an update once we have more information.
Posted Nov 17, 2022 - 12:42 UTC
Update
As of 11:50 UTC, on further investigation, our Engineering team found that this issue is impacting Spaces and App Platform users along with the DigitalOcean Container registry in the NYC3 region. At this time, users may experience errors while interacting and authenticating with the DigitalOcean Container Registry, creating new container registries, and pushing/deleting images to/from registries.

App Platform users may experience build failures.

We apologize for the inconvenience and will share an update once we have more information.
Posted Nov 17, 2022 - 12:09 UTC
Investigating
As of 10:45 UTC, our Engineering team is investigating an issue with DigitalOcean Container Registry in the NYC3 region. At this time, users may experience slow responses or errors while interacting and authenticating with the DigitalOcean Container Registry, creating new container registries, and pushing/deleting images to/from registries.

We apologize for the inconvenience and will share an update once we have more information.
Posted Nov 17, 2022 - 11:13 UTC
This incident affected: Services (App Platform, Container Registry, Spaces) and Regions (NYC3).