Cloud Control Panel
Incident Report for DigitalOcean
Resolved
Our Engineering team has confirmed that the issues impacting the Cloud Control Panel, including event failures while deploying new resources and registration of new accounts, are fully resolved.

If you continue to experience problems please open a ticket with our support team. Thank you for your patience and we apologize for the inconvenience.
Posted Jun 03, 2022 - 18:45 UTC
Monitoring
Our Engineering team identified an issue impacting the Cloud Control Panel. Beginning around 16:00 UTC, users may have experienced event failures while deploying new resources, including but not limited to, Droplets, Snapshots, Volumes, and Apps. Users may also have been unable to create new cloud.digitalocean.com accounts. The API was unaffected.

A fix has been deployed and we are monitoring the situation. We will post another update once we confirm it is fully resolved.
Posted Jun 03, 2022 - 17:45 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).