Cloud Control Panel Login
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue impacting the Cloud Control Panel, and users should now be able to login to cloud.digitalocean.com normally. We apologize for the inconvenience, and thank you for your patience during this process. If you encounter any further problems, then please create a ticket with our support team right away.
Posted Jan 05, 2022 - 07:40 UTC
Monitoring
Our Engineering team has identified the issue and has implemented a fix to resolve the issue with login attempts. We are currently monitoring the situation, and we will post an update as soon as the issue is fully resolved.
Posted Jan 05, 2022 - 07:06 UTC
Investigating
Our Engineering team is investigating issues with login attempts to our Cloud Control Panel (cloud.digitalocean.com. During this time, users may experience failures when logging to their DigitalOcean panel. We apologize for the inconvenience and will share an update once we have more information.
Posted Jan 05, 2022 - 06:07 UTC
This incident affected: Regions (Global) and Services (Cloud Control Panel).