Cloud Control Panel Errors with Billing
Incident Report for DigitalOcean
Resolved
Our engineering team has resolved the issue with the billing page in our control panel. If you continue to experience problems, please open a ticket with our support team via email to support@digitalocean.com. We apologize for any inconvenience.
Posted 4 months ago. Feb 25, 2019 - 19:36 UTC
Monitoring
Our engineering team has implemented a fix to resolve the issue with errors in the control panel and is monitoring the situation. We will post an update as soon as the issue is fully resolved.
Posted 4 months ago. Feb 25, 2019 - 16:55 UTC
Identified
Our engineering team has identified the cause of the issue with the billing page in the control panel and is actively working on a fix. We will post an update as soon as additional information is available.
Posted 4 months ago. Feb 25, 2019 - 16:38 UTC
Investigating
Our engineering team is currently investigating connectivity issues with the billing page in the Cloud Control Panel. Currently, users may experience difficulty accessing the billing portion of the control panel. We apologize for the inconvenience and will share an update once we have more information.
Posted 4 months ago. Feb 25, 2019 - 15:58 UTC
This incident affected: Services (Cloud Control Panel).