Errors Adding Billing Profile for New Users
Incident Report for DigitalOcean
Resolved
Our Engineering team has resolved the issue preventing new users from adding a billing profile to their account. If you continue to experience problems, please open a ticket with our support team. We apologize for any inconvenience.
Posted Oct 01, 2020 - 01:21 UTC
Monitoring
Our Engineering team has identified the cause and implemented a fix to resolve the issue preventing new users from adding a billing profile for their account. We are currently monitoring the situation and will post an update as soon as the issue is fully resolved.
Posted Oct 01, 2020 - 01:00 UTC
Investigating
Our Engineering team is investigating an issue preventing new users from adding a billing profile for their account. During this time, new users may receive 400 errors when adding billing details. We apologize for the inconvenience and will share an update once we have more information.
Posted Sep 30, 2020 - 23:37 UTC
This incident affected: Regions (Global) and Services (Billing).